
UDOT Standard Summary Sheets 
 
The following Excel spreadsheets are available in the M:\CAD_Standards\Resources\Summary_Sheets directory 
or on the internet at http://www.dot.utah.gov (see image below) for use as project summary sheets: 
 
Barrier Summary Sheet.xls 
Concrete Summary Sheet.xls 
Delineator Summary Sheet.xls 
Drainage System Summary Sheet.xls 
Driveways Summary Sheet.xls 
Dust Control and Watering Summary Sheet.xls 
Earthwork Summary Sheet.xls 
Fencing and Gates Summary Sheet.xls 
Generic Summary Sheet.xls 
Landscape Seeding Summary Sheet.xls 
Pavement Marking Acrylic Summary Sheets.xls 
Pavement Marking Epoxy Summary Sheet.xls 
Pavement Marking Paint Summary Sheet.xls 

Pavement Marking Removal Summary Sheet.xls 
Pavement Marking Tape Summary Sheet.xls 
Pavement Sawing Summary Sheet.xls 
Pipe Culverts Summary Sheet.xls 
Relocation Summary Sheet.xls 
Removal Summary Sheet.xls 
Right-of-Way Markers Summary Sheet.xls 
Rotomilling Summary Sheet.xls 
Sign Schedule Summary Sheet.xls 
Surfacing PCCP Summary Sheet.xls 
Surfacing Summary Sheet.xls 
Temporary Erosion Control Summary Sheet.xls 
Temporary Fence Summary Sheet.xls 

 
These files are not automatically copied into the project when a project is created using the Cadd Utilities 
Program.  You will need to manually copy the spreadsheets that are needed for the project to the 
N:\Projects\NNNNN_YY\Quantities\Summary_Sheets directory.  If a spreadsheet needed for the project is not 
included in the standard spreadsheets, use the Generic Summary Sheet.xls as a template for the new 
spreadsheet. 
 
NOTE:  Always check the formulas and values used in determining quantities for accuracy.  The formulas may 
have errors and the values used may not be applicable to your specific project.  These Excel spreadsheets are 
provided as a template and do not replace your responsibility to calculate correct quantities for the contractor. 

 

 

To access the summary sheet downloads from the home web page, select the Doing Business tab, Consultant Resources, CADD Support.  In 
the CADD Support web page, select MicroStation Downloads in the Subtopics area and then in the Download Listing area scroll down to the 
Summary Sheets download.

http://www.dot.utah.gov


General Comments about the Excel Spreadsheets 
 
• The Excel spreadsheets provided by UDOT use named cell ranges to identify standard areas that are 

imported into the PDBS program.  The named cell ranges are used by the Export Quantities to PDBS macro 
and are: 
ItemNumberRow This row defines which columns are exported to the text file.  If a cell in this row has 

data, the macro will use the data for the file name and export the data from that 
column to the file.  Hidden or empty cells are skipped.  Remember to not use an * 
character in these cells.  Replace the * in the bid item number with an S. 

ItemDescriptionRow This row is used to add a description to the include item prompt. 

TopDataRow This row defines where the macro will begin exporting data to the text file. 

BottomDataRow This row defines where the macro will stop exporting data to the text file. 

AlignmentColumn Defines column used for exporting Alignment/Line data. 

FromStationColumn Defines column used for exporting From Station data. 

FromOffsetColumn Defines column used for exporting From Offset data. 

ToStationColumn Defines column used for exporting To Station data. 

ToOffsetColumn Defines column used for exporting To Offset data. 

RemarksColumn Defines column used for exporting Remarks data. 

 

 

 

 

 

 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
• Make sure the named cell ranges are defined correctly.  Named cell ranges can be edited by going to 

Insert>Name>Define.  To change the locations of the named cell ranges, select the named cell range in the 
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define name dialog box and change the information in the Refers to: dialog.  Another way of changing the 
definitions is to delete all of the named cell ranges and allow the macro to prompt for the location of each 
named cell range. 

              
 
• Depending of security settings in Excel, accept the prompt to enable macros.  If the macro security setting is 

set to high, the macro will not run.  If set to medium, you will be prompted to enable the macro.  There will not 
be any notification if the security setting is set to low. 

 
• Hide the rows or columns that are not needed for the Excel spreadsheet.  Deleting the row or column is also 

possible but beware of the columns that have merged cells.  The text for merged cells is usually contained in 
the first column.  Deleting the first column would also delete the text of the merged cell (Axiom Office Importer 
also has linking problems with the hidden column that contains the text of the merged cells).  

 
• Add columns and rows as needed.  For columns of bid items, be sure to add bid item number and bid item 

description in the appropriate rows. 
 
• Enter data into Excel spreadsheet.  The cells in the station and offset columns have custom formats defined 

that will display the numbers correctly.  For stations, enter the station as a whole number (i.e. 3456.34 will 
display as 34+56.34).  For offsets, enter the offsets as positive numbers for offsets to the right and negative 
numbers for offsets to the left (i.e. 23.56 will display as 23.56 RT and -23.56 will display as 23.56 LT).  A zero 
will display as 0.00 RT. 

 

Exporting to PDBS Text Files 
 
1) SAVE THE FILE!  Make sure the spreadsheet file is saved before executing the macro.  The macro alters the 

file in order to create the exported text files. 
 
2) To execute the macro, click on the macro button in the upper left hand corner of the Excel spreadsheet.  If the 

named cell ranges are not defined, the macro will prompt for the location of each named cell range.  For 
named cell ranges that specify rows, select the row desired.  For named cell ranges that specify columns, 
select the top data cell in the column. 



                
 
 
3) When the macro runs, there will be a separate file created for each bid item number displayed (not hidden) in 

the Excel spreadsheet.  The file name will be the bid item number with the extension of .txt.  For bid item 
numbers that are included in PDBS for information only, toggle on the information only and the code of 361 
will be added to the text data.  Save all text files in the N:\Projects\NNNNN_YY\ 
Quantities\Summary_Sheets\PDBS_Export_Data directory. 

         
 
4) After the macro has finished exporting to the different text files, notice the filename of the Excel spreadsheet.  

It has changed to the name of the last text file.  This is the reason for saving the file before running the macro.  
At this point, you can close the file without saving to restore the file back to the way it was before running the 
macro.  If you want to keep the tabs that were created by the macro, you can select File>Save As and save 
the file back to the original location, name and file type (notice that the file type is set to “Text (MS-DOS) 
(*.txt)” and needs to be changed to “Microsoft Excel Workbook (*.xls)”. 

 
Note:  If an error occurs when the macro runs, it will usually exit the command and go to column Z with an error 

message.  Common causes for the macro to crash are invalid named cell ranges and no data in between 
the TopDataRow and BottomDataRow named cell ranges.  

 
For questions or support with importing the text files into the PDBS system, refer to the PDBS Estimate 
help.  If the help file does not answer your questions, contact Thom Leholm at (801)965-4344, 
TLEHOLM@utah.gov or Blaine Bailey at (801)965-4343, BLAINEBAILEY@utah.gov . 



Importing Excel Spreadsheets Into MicroStation 
 
There are two methods used to import the Excel spreadsheets into MicroStation with links.  The first is with the 
use of an MDL program from Axiom International called Microsoft Office Importer.  The second method is to use 
the combination of the programs Microsoft Excel 2002 (with SP1) and MicroStation v8.  With this combination of 
Excel and MicroStation versions, the windows clipboard limitation is eliminated allowing large spreadsheets to be 
pasted into MicroStation.  All parameters included below are based on a MicroStation sheet file with the plotting 
scale of 1 ft = 1 in. 
 

Axiom’s Microsoft Office Importer 
 
Note:  For a detailed explanation of how the program works, consult the user guide delivered with the product 
which is located on the region servers at M:\Cadd_Apps\Axiom\V8\office\office.pdf 
 
Procedure for importing links into MicroStation: 
 
1) Create a sheet file and attach the border file as a reference. 
 
In Excel, highlight the area to be linked to the sheet file and copy into the windows clipboard.  Axiom recommends 
using a named cell range for the highlighted area.  The following explanation is given: 
 

“Using a named range will result in later edits and updates showing added or deleted rows and 
columns in the imported area in the design file. This means the size of the imported area will 
expand or contract when you change the number of rows or columns during an Edit and Update. 
 
Not using a named range when you copy Excel data will result in later Edit and Update processes 
not changing the number of rows or columns of the imported area. If rows or columns are deleted 
during the edit, rows and columns adjacent to the original copied area will be moved into the 
imported area to maintain the same number of rows and columns.” (Axiom International, 
Microsoft Office Importer User’s Guide 2003, 34) 

 
2) Launch Axiom Microsoft Office importer.   

 
 
3) Check the active settings by selecting the Set Microsoft Office Importer Parameters button.  The settings for 

text height and text width in the general category should be set to 0.007 for a medium text size and 0.006 for 
a small text size.  Make sure the “Create links when imported data is pasted” toggle is on to have the data 
updated when changes are made to the spreadsheet. 



         
 
4) Select Paste Clipboard Contents and position the contents in the border. 

 
 
5) Turn on the graphic group lock if manipulation of the link is desired (i.e. move, rotate, scale, delete, etc.). 
 
Updating Links with Microsoft Office Importer 
 
1) Automatic updating can be accomplished by making sure the Update automatically when design file opens 

toggle is selected when the link is placed in the drawing.  The Axiom.cfg file that is found in the C:\Program 
Files\Bentley\Program\MicroStation\config\appl directory needs to have the following line added: 

 
MS_DGNAPPS > $(AXI)office/office.ma 

 
This change to the configuration file will load the Microsoft Office Importer program when MicroStation is 
opened.  If you want to have the Microsoft Office Importer program automatically unload after performing the 
link updates, select the Unload Microsoft Office Importer when automatic updates are completed toggle in the 
preferences import link category. 

 
 

2) Manual updating is accomplished by selecting the Manage Import Link button from the main Microsoft Office 
Importer toolbar.  With this utility, you can update the location of the source file, change the automatic 
updating selection, open and edit the spreadsheet designated by the source, update the link, and unlink the 
MicroStation graphics. 

 
 



The link will only update if there has been a change in the spreadsheet file and the spreadsheet file has been 
saved.  If Microsoft Office Importer does not detect a change in the file, it will report “The source document is 
up to date” in the MicroStation’s Message Center. 



MicroStation’s Paste Special 
 
Note:  This procedure only works for large spreadsheet links if the Microsoft Excel 2002 (with SP1) and 
MicroStation v8 programs are used.  Smaller links are possible using the same procedure described below with 
any versions of Microsoft Excel and MicroStation. 
 
Procedure for importing links into MicroStation: 
 
1) Create a sheet file and attach the border file as a reference. 
 
2) In Excel, make sure the spreadsheet has the gridlines turned off in the view control found in 

Tools>Options>View. 

 
 
3) Highlight the area to be linked to the sheet file and copy into the windows clipboard. 
 
4) In MicroStation, select Edit>Paste Special. 

 



 
5) Choose the Linked Microsoft Excel Worksheet option in the Paste Special window and then select Paste. 

 
 
6) In the Paste OLE window, change the Method to By Size and change the Scale to 8.75 for medium size text 

or 7.50 for small size text. 

 
 
7) Position the contents in the border.  When the link is first placed in MicroStation it has a hatching appearance 

which disappears after the sheet file has been reopened. 
 
8) After placement, the link element can be manipulated like a shape element (i.e. move, rotate, scale, etc.). 
 
Updating Links with MicroStation 
 
1) To update the link, go to Edit>Update Links.  MicroStation will automatically scan the file for links and update 

them if they have been changed. 

 
 



2) To edit the link, go to Edit>Links.  In the Links window, you can update, open the spreadsheet source, change 
the link source, and break the link. 

 
 
 
 
 
 
 
 
 
 

Pros and Cons (Microsoft Office Importer vs. Paste Special) 

 

 Microsoft Office Importer Paste Special 

Pros Imports link as text and line 
graphics.  Iplot Professional can print 
without problems. 

Don’t need 3rd party software for 
import. 

 Maintains text height when rows or 
columns are changed. 

Follows Microsoft functionality for 
paste special. 

   

   

Cons Data in column headings is 
sometimes lost when columns are 
hidden. 

Iplot Professional is not able to print 
the linked element. 

 Potential of different links being 
combined into same graphic group.  
When one link is deleted, another is 
deleted unintentionally. 

If rows and columns are altered after 
the link to the sheet file, the link 
maintains it’s shape size altering the 
text height. 

 Text can be edited in MicroStation 
but not reflected back to Excel.  The 
edited MicroStation text is not 
maintained once the link is updated. 

Displays gridlines. 
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